2
Vote

2013

description

I wish you could upgrade it for 2013

comments

SteveB wrote Mar 13, 2014 at 11:03 AM

The tools is compatible, with a bit of tweak.

In the same folder than the executable, create a file "SharePointEventReceiverManager.exe.config".

Paste in this file the following content:
 <configuration>
    <startup>
        <supportedRuntime version="v4.0"/>
    </startup>
    <runtime>
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
            <dependentAssembly>
                <assemblyIdentity name="Microsoft.SharePoint" publicKeyToken="71e9bce111e9429c" culture="neutral" />
                <bindingRedirect oldVersion="11.0.0.0" newVersion="15.0.0.0" />
            </dependentAssembly>
            <dependentAssembly>
                <assemblyIdentity name="Microsoft.SharePoint" publicKeyToken="71e9bce111e9429c" culture="neutral" />
                <bindingRedirect oldVersion="12.0.0.0" newVersion="15.0.0.0" />
            </dependentAssembly>
            <dependentAssembly>
                <assemblyIdentity name="Microsoft.SharePoint" publicKeyToken="71e9bce111e9429c" culture="neutral" />
                <bindingRedirect oldVersion="14.0.0.0" newVersion="15.0.0.0" />
            </dependentAssembly>
        </assemblyBinding>
    </runtime>
</configuration>
Then the appliction will be able to launch.

For a bit of background, this config file force the .Net v4 runtime instead of the V2. It also redirect old SharePoint Dll reference to the new one.

Rockie wrote Feb 29, 2016 at 2:12 PM

Since .NET and CLR 4 there is another GAC structure, so GAC deploy process is another too.

You can take a look at EventHandlerExplorer 2013 instead

Best regards,
Gennady